unusual trace editing behavior

Report bugs here
Post Reply
Message
Author
Tomg
Expert
Posts: 1910
Joined: 20 Jun 2015, 14:39

unusual trace editing behavior

#1 Post by Tomg » 17 Sep 2022, 10:04

1) Place two Static Vias into a new PCB layout and route a straight trace (Free Line segment mode) between them...
otb1.png
2) Enable the Edit Traces mode, drag the lower-right portion of the trace upwards without releasing the mouse button and observe that the left side of the trace disappears...
otb2.png
3) Releasing the mouse button returns the trace to its original state without implementing any changes...
otb3.png
This anomaly does not occur in the Free Trace Editing mode even though it does, confusingly, insert two nodes instead of one. Manually adding one node as a dragging point can fix that behavior.

The problem only seems to appear when dragging a trace in the Edit Traces mode. Adding a node as a dragging point and having an available 45-degree path does not provide a solution.
You do not have the required permissions to view the files attached to this post.
Tom

Alex
Technical Support
Posts: 3736
Joined: 14 Jun 2010, 06:43

Re: unusual trace editing behavior

#2 Post by Alex » 22 Sep 2022, 02:15

Thank you for the report. We will investigate the behaviour

ken.howard
Posts: 3
Joined: 07 Dec 2020, 01:03

Re: unusual trace editing behavior

#3 Post by ken.howard » 05 Oct 2022, 23:27

Possibly related to the above report.
DipTrace 4.3.0.2, PCB Layout, Manual 45º/90º routing selected.

Place a static via close to a pad and route a trace to it like this:
Screen Shot 2022-10-06 at 13.52.16.png
Screen Shot 2022-10-06 at 13.52.37.png
If I now left click on the trace it gets changed to a straight line.
Screen Shot 2022-10-06 at 13.53.00.png
Any attempt to get it back to the original routing results in either the same direct routing, or this
Screen Shot 2022-10-06 at 13.53.17.png
You do not have the required permissions to view the files attached to this post.

Alex
Technical Support
Posts: 3736
Joined: 14 Jun 2010, 06:43

Re: unusual trace editing behavior

#4 Post by Alex » 06 Oct 2022, 10:01

ken.howard wrote:
05 Oct 2022, 23:27
Possibly related to the above report.
DipTrace 4.3.0.2, PCB Layout, Manual 45º/90º routing selected.

Place a static via close to a pad and route a trace to it like this:

Screen Shot 2022-10-06 at 13.52.16.png
Screen Shot 2022-10-06 at 13.52.37.png

If I now left click on the trace it gets changed to a straight line.

Screen Shot 2022-10-06 at 13.53.00.png

Any attempt to get it back to the original routing results in either the same direct routing, or this

Screen Shot 2022-10-06 at 13.53.17.png
This is an optimization that removes very short trace segments. Try to open "Route -> Route Setup -> Settings" and decrease minimum segment option. This will allow shorter segments than now.

Post Reply