Page 1 of 1

unusual trace editing behavior

Posted: 17 Sep 2022, 10:04
by Tomg
1) Place two Static Vias into a new PCB layout and route a straight trace (Free Line segment mode) between them...
otb1.png
2) Enable the Edit Traces mode, drag the lower-right portion of the trace upwards without releasing the mouse button and observe that the left side of the trace disappears...
otb2.png
3) Releasing the mouse button returns the trace to its original state without implementing any changes...
otb3.png
This anomaly does not occur in the Free Trace Editing mode even though it does, confusingly, insert two nodes instead of one. Manually adding one node as a dragging point can fix that behavior.

The problem only seems to appear when dragging a trace in the Edit Traces mode. Adding a node as a dragging point and having an available 45-degree path does not provide a solution.

Re: unusual trace editing behavior

Posted: 22 Sep 2022, 02:15
by Alex
Thank you for the report. We will investigate the behaviour

Re: unusual trace editing behavior

Posted: 05 Oct 2022, 23:27
by ken.howard
Possibly related to the above report.
DipTrace 4.3.0.2, PCB Layout, Manual 45º/90º routing selected.

Place a static via close to a pad and route a trace to it like this:
Screen Shot 2022-10-06 at 13.52.16.png
Screen Shot 2022-10-06 at 13.52.37.png
If I now left click on the trace it gets changed to a straight line.
Screen Shot 2022-10-06 at 13.53.00.png
Any attempt to get it back to the original routing results in either the same direct routing, or this
Screen Shot 2022-10-06 at 13.53.17.png

Re: unusual trace editing behavior

Posted: 06 Oct 2022, 10:01
by Alex
ken.howard wrote:
05 Oct 2022, 23:27
Possibly related to the above report.
DipTrace 4.3.0.2, PCB Layout, Manual 45º/90º routing selected.

Place a static via close to a pad and route a trace to it like this:

Screen Shot 2022-10-06 at 13.52.16.png
Screen Shot 2022-10-06 at 13.52.37.png

If I now left click on the trace it gets changed to a straight line.

Screen Shot 2022-10-06 at 13.53.00.png

Any attempt to get it back to the original routing results in either the same direct routing, or this

Screen Shot 2022-10-06 at 13.53.17.png
This is an optimization that removes very short trace segments. Try to open "Route -> Route Setup -> Settings" and decrease minimum segment option. This will allow shorter segments than now.