4.0.0.5 "View > Add to Assembly > Component Boarders" does not work if footprint contains an assembly layer

Report bugs here
Post Reply
Message
Author
nqtronix
Posts: 7
Joined: 09 Aug 2020, 02:56

4.0.0.5 "View > Add to Assembly > Component Boarders" does not work if footprint contains an assembly layer

#1 Post by nqtronix » 27 Nov 2020, 08:47

The feature "View > Add to Assembly > Component Boarders" does not work if footprint contains anythin in the assembly layer. I assue this is because some people use/ used the assembly layer for the component outline. With the new update this is fortunatly no longer required:

1. Comp Outline contains the nominal outline of the part that touch the PCB
2. Courtyard is the rough placement area
3. Therfore Assembly should be only additional assmebly information

I want to put a pin 1 marker into the assembly layer. In PCB layout I enable "View > Add to Assembly > Component Boarders" and "View > Component Markings > Assembly: RefDes show center" to generate a diagram for manual assembly. This is very useful for dense layouts where you can not have refdes in the silkscreen layer. It would be great if the components' assembly layer could contain polarity information (or other information) as well. Using "View > Add to Assembly > Component Silk Screen" is rather useless as the triangle in the center covers the RefDes.

An example is the attached screenshot. Both parts are identical, except the right one has a dot polarity marker added in the assembly layer and thus does not have the outline.
You do not have the required permissions to view the files attached to this post.

Post Reply