Copper Pour Pad Connections Ignored in Mouseover Gui Color Coding

Report bugs here
Post Reply
Message
Author
User avatar
ReverseEMF
Posts: 57
Joined: 02 Jun 2012, 12:51
Location: Utah
Contact:

Copper Pour Pad Connections Ignored in Mouseover Gui Color Coding

#1 Post by ReverseEMF » 29 May 2019, 13:22

You know how when you run your mouse pointer over a trace, all the pads, on the same net, light up either red or cyan, depending on if they are connected or not: Red for NOT connected, and Cyan for connected?

Well, I noticed that a couple of capacitors, sitting within the bounds of a Copper Pour, showed pads as Red, when, indeed, they were actually connected to the same net associated with the Copper Pour!

I attached a series of screen shots that hopefully tell the rest of the story.

Notice that in sshot04, I tried removing the direct trace connection to C6, to see if that made a different -- it did: both C6 and C7 display pads indicated as "not connected" based on their Red coloration -- even though they are connected -- as evidenced by the fact that a Net Connectivity test reports "No Errors Found". Also, as can be seen in the close-ups of that region [sshot02 & sshot03], the connections are clearly there.
You do not have the required permissions to view the files attached to this post.
Last edited by ReverseEMF on 29 May 2019, 13:31, edited 2 times in total.
If left to evolution, would this PCB ever design itself, and what would the lead time be on that?

User avatar
ReverseEMF
Posts: 57
Joined: 02 Jun 2012, 12:51
Location: Utah
Contact:

Re: Copper Pour Pad Connections Ignored in Mouseover Gui Color Coding

#2 Post by ReverseEMF » 29 May 2019, 13:27

The final 4 screenshots:
You do not have the required permissions to view the files attached to this post.
If left to evolution, would this PCB ever design itself, and what would the lead time be on that?

farley
Posts: 130
Joined: 15 Sep 2011, 16:28

Re: Copper Pour Pad Connections Ignored in Mouseover Gui Color Coding

#3 Post by farley » 29 May 2019, 15:02

On my DipTrace installation:
Hovering over any pad, whether connected to a plane or trace, or unrouted, will show all the other pads on that same net as red.
Hovering over a trace will show connected traces and pads in cyan.
Hovering over a pour does not highlight any pads.

Post Reply