has anyone used Samacsys? to source a component or build one

Making your own components and patterns, organizing and using libraries.
Post Reply
Posts: 3
Joined: 26 May 2016, 15:51

has anyone used Samacsys? to source a component or build one

#1 Post by AyalaResearch » 09 Aug 2019, 03:44

The site supposedly has a very large library of parts, they also state they have really good tools for quickly making one's own library component. This is all free according to the site. I can't help but wonder, what's the catch? Perhaps it's underwritten by component manufacturers, and if you build your own model; because they don't have one, perhaps they have the right to it, which would also benefit that particular manufacturer. That wouldn't strike me as an unfair trade off.

If you've used the site, what's your experience?

Posts: 7
Joined: 12 Apr 2019, 19:07

Re: has anyone used Samacsys? to source a component or build one

#2 Post by dudemanbroguy » 06 Sep 2019, 20:45

I just tried it out last night and it worked alright but leaves a bit to be desired. For small stuff I think it would be great, and it seems to have a pretty good set of already implemented parts. As for the catch it didn't seem to have any from what I can see. Perhaps, like you said, some of the big vendors are supporting it. I noticed mouser seems to be pretty involved with all the embedded links in their component details pages. It would be the perfect tool if not for a couple big issues I had with the experience.

Before I get into the issues I had with it let me explain what I was using it for. I needed a symbol for a Cyclone 10 LP FPGA from intel/altera, and since the cyclone 10 family is so new there wasn't any one I could use in the default library. It gets really tediouse to manually type out or copy and paste pin names when you are talking parts with >200 leads. The IBIS files didn't have any alternate functions in the pin names so importing them really didn't help much. What I wanted to do was use the "import .csv" function of Samacsys to import a cleaned up version of the pinout excel file intel has on their website. This worked okay (I had to do a workaround to create a new part since the publicly available ones are read only so you can't update the pin names if you want to add more info) and I was able to generate the part. However this is when I ran into

Issue 1: The schematic symbol that is generated cannot be edited at the time of creating it. Here is a screenshot of the footprint and model that were generated, as well as part of the list of info I was able to pull in from the .csv file
generated bga.png
I was able to generate the file and import it without much trouble but when dealing with this many pins you get a symbol like this.
generated image.png
I looked around to find ways to edit the symbol before import so I could make it more usable but there isn't any way inside the system to do that. There is a couple of programs they offer for free that you import their file into and manipulate it but they are excel based and really leave a lot to be desired. I was able to use them to clean things up but it was a bit finicky.

Issue 2: There is some weird bugs with how text gets converted when importing into diptrace. For example spaces in the text used in the Samacsys pin name list become underscores in diptrace, backslashes become a tilde, etc. I tried generating an eagle library and importing it to see if the issue was related to how it generated the diptrace ASCII file, but still had the issue.

Issue 3: This one is more of a diptrace thing I think but after import the part had the generated pattern attached but when I opened the pattern editor to check the 3D model I had a lot of trouble actually finding it. From what I can tell, when I imported the part everything was sort of embedded into the symbol. When I would try to find the pattern in the pattern editor it wouldn't show up (it also wouldn't show up in the pattern list when associating a pattern to a symbol). I used the manage libraries menu and tried to manually add the library but got errors. I was able to re-import the generated diptrace file inside of the pattern editor itself and got everything working properly. I also want to note that the generated 3D file was pretty nice but diptrace starts to struggle with rendering it in the preview. I am assuming it is due to the part having all the balls generated and being overly complex.

All in all I think it is nice for generating 3D models and footprints for standard parts. I also LOVE the fact that you can add pin names from a .csv file (take the hint diptrace wink wink) so I will definitely be using it more in the future. Just keep in mind that it is not the magical tool it makes itself out to be in all the promotional stuff on their website.
You do not have the required permissions to view the files attached to this post.

Post Reply