Via in Pad shows covered

Making PCB Layouts, Manual routing, Auto-routing, Copper pouring, Updating from Schematic, Manufacturing Output
Post Reply
Message
Author
WaynePace
Posts: 3
Joined: 03 Oct 2022, 17:57

Via in Pad shows covered

#1 Post by WaynePace » 03 Oct 2022, 18:20

I am trying to replicate a board we no longer have the design files for. It has a via overlapping a pad area. I would really like to have the hole in the via visible for the preview to print for documentation. The hole is there in the 3D view, but I cannot seem to figure out how to get the via hole to take precedence over the pad. I am very new to DipTrace and I am not sure if there any way to do this?

Attached image is the board I am trying to recreate, the DipTrace view and the DipTrace preview.
You do not have the required permissions to view the files attached to this post.

Alex
Technical Support
Posts: 3736
Joined: 14 Jun 2010, 06:43

Re: Via in Pad shows covered

#2 Post by Alex » 04 Oct 2022, 15:18

What is your DipTrace version? I can't reproduce the problem in version 4.3.0.2.
Could you upload the file on the forum?

WaynePace
Posts: 3
Joined: 03 Oct 2022, 17:57

Re: Via in Pad shows covered

#3 Post by WaynePace » 05 Oct 2022, 08:40

I am using Revision 4.2.0.1
You do not have the required permissions to view the files attached to this post.

WaynePace
Posts: 3
Joined: 03 Oct 2022, 17:57

Re: Via in Pad shows covered

#4 Post by WaynePace » 05 Oct 2022, 08:51

The rectangle areas are pads added as surface with a square shape option. They were not added as a component footprint.

Tomg
Expert
Posts: 1910
Joined: 20 Jun 2015, 14:39

Re: Via in Pad shows covered

#5 Post by Tomg » 05 Oct 2022, 09:00

That "via" is actually a through-hole pad, which means you have a surface mount pad covering over a through-hole pad. Change the "via" (through-hole pad) into a real via and your problem will go away.
Tom

Post Reply