Connecting components to interior layers

Making PCB Layouts, Manual routing, Auto-routing, Copper pouring, Updating from Schematic, Manufacturing Output
Post Reply
Message
Author
NLSA
Posts: 4
Joined: 26 Jul 2014, 07:03

Connecting components to interior layers

#1 Post by NLSA » 17 Apr 2021, 12:51

Dear friends,
I am designing my first 4-layer board. I need help in connecting top-side components to interior layers.
The 2nd layer of my board is the "digital" layer where I2C traces will run. I created a net class "I2C" and assigned my I2C-related nets to it. In the Autorouting tab of the Net Classes dialog, I assigned the I2C class to the digital layer. When I autoroute, the I2C class seems to be *strictly* confined to the Digital layer, which means that none of my surface-mount component pads have through-vias to connect them to the digital layer. This can't be right... what am I missing?
Thank you-
MRO

Tomg
Expert
Posts: 1739
Joined: 20 Jun 2015, 14:39

Re: Connecting components to interior layers

#2 Post by Tomg » 17 Apr 2021, 15:46

From what I can see the DipTrace (v4.1.2.0) autorouter has no problem routing to the second layer between existing through-hole pads, but SMD pads are another story.

As far as I can tell the autorouter is not automatically doing fanouts as one might expect it should. If the "[x]Vias at SMD Pads" option is enabled it will place vias right in the middle of SMD pads and then route to the second layer. You will then be forced to manually drag each via clear of its respective pad. There is no difference when the "[x]Fit Inside" option is enabled, either. I wonder if this may be an autorouter bug, because according to my "logic" there should be a difference between those two options. I would assume that the "[x]Vias at SMD Pads" option would place fanout vias outside and next to SMD pads and the "[x]Fit Inside" option would do the "right-in-the-middle-of-the-SMD-pad" thingy.

Further reading in the help file states that "[x]Vias at SMD Pads" places vias inside SMD pads and "[x]Fit Inside" centers vias inside SMD pads. These options should be renamed to be more intuitive.

So far the only way I could get the autorouter to route the desired net class on the second layer without choking or dropping vias inside SMD pads was to first manually fan out all of the second-layer-net components/pads and then run the autorouter. However, I could be overlooking another setting somewhere (it wouldn't be the first time) that would remedy this problem.
srs.png
all2.png
This might have something to do with not allowing routing of the net class on the component layer. Still, the autorouter algorithm should at least allow fanouts of the specified maximum length on the component layer.

p.s. According to the help file, on the Schedule tab: "[x]SMD Fanout – create fanouts for SMD pads before starting the autorouting, the value sets the number of passes." Apparently, it doesn't work as expected.
You do not have the required permissions to view the files attached to this post.
Tom

NLSA
Posts: 4
Joined: 26 Jul 2014, 07:03

Re: Connecting components to interior layers

#3 Post by NLSA » 17 Apr 2021, 19:00

Tom - Thank you for the thoughtful comments. It's good to know that I'm not missing something obvious.

User avatar
KevinA
Posts: 564
Joined: 18 Dec 2015, 15:35

Re: Connecting components to interior layers

#4 Post by KevinA » 17 Apr 2021, 19:57

With vias in place and set to the net they should be the router will not route on the top layer only layer 2
inner2.jpg
All you have to do is drop a via, manual route from the pad to the via, it is assigned the net of the pad.
You do not have the required permissions to view the files attached to this post.

NLSA
Posts: 4
Joined: 26 Jul 2014, 07:03

Re: Connecting components to interior layers

#5 Post by NLSA » 18 Apr 2021, 07:00

Kevin -
Thank you. I rather expected it to be automatic but I guess not.
MRO

Post Reply