Page 1 of 1

EAcessViolation

Posted: 02 Mar 2019, 01:45
by matttay
Out of the blue I've just started getting EAccessViolation errors on 3.2 (or whatever was out in early 2018). So, I took that as an opportunity to uninstall and install 3.3. But the problem persists. This is Win10.

I've uninstalled and re-installed. I've rebooted. The launcher works, but whether I use the launcher or click on schematics.exe I get the same fault. If I run as admin it's the same too. Install dir is default. If I run the schematic.exe under ProcMon, I can see the last thing the app does is optn a registry key hkcu\software\microsoft\ctf\directswitchhotkeysd and then dies. That is consistent in ProcMon. Looking in RegEdit, that entry is empty.

No virus software, except defender. But that hasn't been changed by me in a long time, if ever.

My license is for the Extended package.

Any thoughts on next steps? Thanks

Re: EAcessViolation

Posted: 04 Mar 2019, 09:41
by Alex
You can run DipTrace executables as administrator or reinstall DipTrace to custom folder. In second case, good place is non system drive or root folder of system drive but nether Program Files nor Documents.