Problem with compoment name changing and value missing

For general questions regarding the software and for all questions that do not fit in any of the threads above.
Post Reply
Message
Author
auto-mation-assist
Posts: 2
Joined: 01 Feb 2021, 00:25

Problem with compoment name changing and value missing

#1 Post by auto-mation-assist » 16 Mar 2021, 19:59

I have been self training on Diptrace and having some issues with errors being generated in my library files. I use the a library as a regular file with library name being the same as the component it contains. Thus each component has its own file with the .eli extension. So the .eli file name being the same as the component within it. Very simple. When in the schematic editor and highlighting a component and selecting properties I have seen that in a good number of occasions that the component name has changed on this own and no longer agrees with the name of the component file itself. Somehow it inserts the name of a other valid component. I do not know when or why this occurs but can see that this is a problem.

Yesterday in set the value field in all the components that I have used in the schematic so that I can seen resistors values in ohms and so forth. I manually updated each component in the schematic so that they would contain the added information. Then worked on the PCB a bit and updated the numbering of the components, then did a back plot in the schematic and all the added value data is missing. But it is OK in my component files and updating from the library files puts the values back in but that is a very time consuming process since I have not found a way to update every component at once.

I would like to see the actual contents of the .eli file so that they can be directly edited after unpacking and then repacking them when and if edits are made. Is there a utility that can do this?

Post Reply