Author Message
 Post subject: SPICE model setup for multi-part component PWR pins
PostPosted: 25 Sep 2017, 10:18 
Offline

Joined: 25 Sep 2017, 10:05
Posts: 2
Currently I am trying to set up the spice model setting in the component editor. This case is for 74HC00 4XNAND component.

I have setup 4NAND + 1PWR components for this component as shown in the tutorial. The model I will be linking this component to is defined:


.SUBCKT 74HC00 A B Y VCC VGND vcc1={vcc} speed1={speed} tripdt1={tripdt}
.param td1=1e-9*(9-3-3)*4.0/({vcc1}-0.5)*{speed1}
*
XIN1 A Ai VCC VGND 74HC_IN_1 vcc2={vcc1} speed2={speed1} tripdt2={tripdt1}
XIN2 B Bi VCC VGND 74HC_IN_1 vcc2={vcc1} speed2={speed1} tripdt2={tripdt1}
* tripdt=1n
A1 Ai Bi 0 0 0 Yi 0 0 AND tripdt={tripdt1} td={td1}
*
XOUT Yi Y VCC VGND 74HC_OUT_1X vcc2={vcc1} speed2={speed1} tripdt2={tripdt1}
.ends



The problem I am facing is with the VCC and VGND. As there are no VCC/GND pin for each of the components (except for PWR), I cannot reference the VCC/GND net to the individual component. Is there a way to reference the pin from other components? Are there any alternative solutions?


Regards


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group