DipTrace Forum
http://www.diptrace.com/forum/

Converter32 Issue with 3D render on Ubuntu 16.04
http://www.diptrace.com/forum/viewtopic.php?f=9&t=11683
Page 1 of 1

Author:  kammce [ 12 Jul 2017, 16:47 ]
Post subject:  Converter32 Issue with 3D render on Ubuntu 16.04

When I attempt to use 3D render on diptrace I get the following in the image.

Converter32/64.dll or other ifles in "Converter32/64" folder produces error. Process failed! Please reinstall the program from complete installation package.

This message pops up continuously and does not release control over the program so I have to force close it.

Note: that I just did a fresh install of the latest Diptrace on my machine.

What should I do to fix this?

Author:  Alex [ 13 Jul 2017, 09:11 ]
Post subject:  Re: Converter32 Issue with 3D render on Ubuntu 16.04

Thank you for the report.
Please try to install 32-bit versions of DipTrace if you have 64-bit version now.
Also we suggest to use 32-bit version of Wine. Try stable and beta versions.
Change graphics mode (View->Graphics Mode from main menu).
Please let me know if nothing helps.

Author:  manny89 [ 11 Oct 2017, 21:25 ]
Post subject:  Re: Converter32 Issue with 3D render on Ubuntu 16.04

I'm having the same issue on my MacBook Pro running OS X 10.10.5 (16GB RAM). I installed DipTrace a few weeks ago. The 3D rendering issue started as an intermittent problem at first. A quit/restart of the app would usually help. Now, 3D rendering won't run at all. I tried rebooting the machine and switched to a very simple 1-2 component circuit. Each time the rendering goes into a loop and eventually produces the same error:

Attachment:
Error_with_3D_Preview.png

After that, the PCB app must be forcefully shut down.

I also tried the suggestions above (different Graphics Mode, etc), though on Mac, I don't see any option to move between 32/64 bit versions.

The 3D rendering feature is one of the big reasons I'm moving over to DipTrace (I've got a tricky enclosure setup and 3D will be imported for mechanical checking).

  • Is there logging (a local log file) that I could check to further debug the issue?
  • What can be done to get this feature working again..?

Any help would be greatly appreciated.

-MG

Author:  Alex [ 12 Oct 2017, 06:46 ]
Post subject:  Re: Converter32 Issue with 3D render on Ubuntu 16.04

What is your DipTrace version now. We suggest to reinstall DipTrace. Correct sequence is the following.
1. Make sure the system has xQuartz installed. Otherwise download and install the latest stable version of xQuartz, logout and login.
2. Remove folder //Users/macuserdip/DipTrace 3.1.0.1/.
3. Move DipTrace 3.1.0.1 from Applications to Trash.
4. Open downloaded DMG file, drag DipTrace 3.1.0.1 from there to Applications.
5. Open Applications, find DipTrace 3.1.0.1 there and start the program.
6. The first start takes a while (more than usual). It shows Wine window during the first start informing about building the prefix then the window is closed and DipTrace is started.

We recommend to put 3D models within Wine prefix //Users/macuserdip/DipTrace 3.1.0.1/ to avoid any problem with access to 3D model files.
Please let me know whether 3D preview works now or not.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/