Author Message
 Post subject: Re: Reference designator in the assembly drawing
PostPosted: 26 Feb 2016, 15:11 
Offline

Joined: 05 Jan 2016, 17:52
Posts: 1
:!: I'll add my vote for this feature too!

Using DipTrace for the first time and think it's a great product but this is a really important feature for board fab that is missing. I'm trying to use the work around of creating two versions of the project with different silk screen layers. One for actual silk screening and the other is a silkscreen for use as an assembly. However, this really isn't a good solution with small SMT parts that are tightly packed - I can't make Ref Des clearly visible on the assembly layer if they are right on top of component location (where they should be for assembly layer) and there is ambiguity if you move them off the pattern location to where they are clearly visible.


Top
 Profile  
 
 Post subject: Re: Reference designator in the assembly drawing
PostPosted: 16 Dec 2016, 23:23 
Offline

Joined: 16 Dec 2016, 23:07
Posts: 1
Yes, please implement this feature, this is important for producing assembly drawings where often placing the designator inside the outline is much clearer than placing it next to it (as is the only option on silkscreen). I've only just started using DipTrace and this is one feature which is lacking in comparison to other packages.

In the meantime, for the information of the other users having the same problem, I have figured out a workaround that doesn't involve 2 different versions. You can take advantage of the fact that DipTrace offers 2 different component markings, "Main" and "Additional" ("View > Component Markings"). If you set both "Main" and "Additional" to "RefDes", you have two copies of RefDes to move individually. If you enable "View > Assembly Layers > Component Markings" as mentioned before, the two copies appear on both the silkscreen and the assembly layers. Now the trick is to treat the RefDes which appears as the "Main" marking as relating to only the silkscreen, and the one as "Additional" as relating only to the assembly (or vice versa), I found that if after positioning the designators you set either "Main" or "Additional" back to "None", it simply hides the label rather than completely deleting it, so then if you set it back to "RefDes" the original position is preserved. So the procedure therefore is:

1) Start with the "Main" marking set to "RefDes", and the "Additional" set to "None". Position the marking as you would like it to appear on the silkscreen.
2) Set the "Main" marking to "None", and the "Additional" marking to "RefDes", enable "View > Assembly Layers > Component Markings". Position the marking as you would like it to appear on the assembly.
3) The only complication now is when exporting the gerbers (or indeed to view the silkscreen or assembly layer correctly) you need to toggle the appropriate marking and either enable or disable the assembly markings.

Of course this method only works if you do not to display other info next to the component other than RefDes. It would be great to have the full functionality implemented as the other users mentioned also, however for now I hope this helps those who encountered this issue.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ]  Go to page Previous  1, 2

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group