Author Message
 Post subject: CAnnot find LED pattern
PostPosted: 12 Mar 2014, 16:31 
Offline

Joined: 18 Oct 2012, 22:09
Posts: 42
I am trying to figure out how to attach a through hole T1 LED pattern to my LED in the schematic so it carries over into the PCB program.

I am searching the libraries but I am missing something


Top
 Profile  
 
 Post subject: Re: CAnnot find LED pattern
PostPosted: 12 Mar 2014, 22:42 
Offline

Joined: 22 Feb 2014, 22:49
Posts: 26
This component is already accessible in the schematic editor in the 'Discrete' library and is named 'LED'.

The 'LED' symbol is located in the '__discrete.eli' schematic library and the accompanying 'LED100' footprint in '_General.lib'.

This is for a standard 3mm through-hole LED with a lead pitch of 100mil or 2.54mm.


Top
 Profile  
 
 Post subject: Re: CAnnot find LED pattern
PostPosted: 12 Mar 2014, 23:53 
Offline

Joined: 18 Oct 2012, 22:09
Posts: 42
YEs, I found it later on.

But what I am now having an issue with is placing the component on the PC Board. I need the LED's as close as I possibly can have them for my matrix display. I have been playing with "Placement Setup" and "Arrange Components" with little success.

How do I tell the PCB program to place the led's really close together?


Top
 Profile  
 
 Post subject: Re: CAnnot find LED pattern
PostPosted: 13 Mar 2014, 00:36 
Offline

Joined: 22 Feb 2014, 22:49
Posts: 26
I'm not sure if it's possible to do that with the auto placer as it does optimizations and so on.

However my advice is to set the grid to the spacing you want and then simply drag each of the LED's to where you want them and they will snap to the grid.

Alternatively double-click on each of the LED's and then enter the X- and Y-coordinates.

This would do the trick for now.


Top
 Profile  
 
 Post subject: Re: CAnnot find LED pattern
PostPosted: 13 Mar 2014, 07:46 
Offline

Joined: 18 Oct 2012, 22:09
Posts: 42
Yeah the manual placement is probably the way to go it just stinks that I cannot get the alignment tool to do the job instead.

I'll post my results when I am making headway.

THanks

-- 13 Mar 2014, 10:37 --

This is really frustrating....

I need to make a 3 inch round PC board and fill it with T-1 sized LED's. When I do the board points, and use the ARD the board always ends up printing 5/8 of an inch bigger.
The other problem is that I must fill this entire 3 inch board with T-1 sized LED's but the only LED footprint in the library is for 5mm T-1 3/4 LED's.

Can anyone give me some tips on how to get this on track?


Top
 Profile  
 
 Post subject: Re: CAnnot find LED pattern
PostPosted: 17 Mar 2014, 03:49 
Offline
Technical Support

Joined: 14 Jun 2010, 06:43
Posts: 2762
We added "Sensors & LED" library in the beta version. You can find many LEDs there.

Regarding round board, open "Objects -> Board Pints", click on "Create Circular Board" option and specify radius. Don't take into accout board points after you pressed OK.


Top
 Profile  
 
 Post subject: Re: CAnnot find LED pattern
PostPosted: 17 Mar 2014, 22:35 
Offline

Joined: 18 Oct 2012, 22:09
Posts: 42
I downloaded the beta version and I looked at the LED and Sensor section and there is nothing there for a through hole T-1 LED

So my question is.
In DipTrace is there a T-1 Through hole led in any of the libraries, or is it just T-1 3/4?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group