Author Message
 Post subject: 3D view of board cutouts not working
PostPosted: 23 Mar 2014, 14:30 
Offline

Joined: 21 Apr 2012, 20:20
Posts: 5
2.3.5.2 Beta Jan 17 build

I can create a board with a polygon cutout, and tested this with a simple polygon, then made them a bit more complex (by hand editing the points, *cough*Excel or CSV import*cough*) to accommodate the fact that they are cut with round mills, but now the polygon does not result in a board cutout.

I can see in the Gerber output that it is still part of the board cutout, but in the 3D view, it has not removed that section of board as it did with the simpler polygon.

If I recreate the shape by selecting Polygon, and clicking over the shape that does not cut the board, I get a polygon the that does cut the board. Save and load - still works. Copy and paste the shape - still works. Flip as group - still works.
Change layers, save the file, restart, reload file, change layer to Board Cutout- still broke.

What is wrong?
- The shape is on the Board Cutout layer
- The board outline is on the Board Cutout layer, and was created by going Objects-> Place Board Outline, then clicking 8 random points.
- I suspect that there is some way to unintentionally cause the polygon to open, either by deleting points (eg first or last) or by wiggling the points around with the mouse.

Attached is the board.
Attachment:
3dCutoutProblem1.png


Attachment:
3dCutoutProblem2.png


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group